Navigation

Tagged: 

  • Author
    Posts
  • #1325745

    emmaandrews
    Participant

    Hey,

    I’m trying to make a whole section a link in cornerstone, preferably with the option to add a rollover state. Is this possible?

    Thanks,
    Emma

    #1325848

    Joao
    Moderator

    Hi Emma,

    Please give an ID to your section for example: link-section-1

    and add the following code to Appereance > Customizer > Custom > JS with the proper url.

    jQuery("#link-section-1").wrap("<a href='http://www.yoursiteurl.co.uk/get-in-touch/'></a>");

    Hope it helps

    Joao

    #1325932

    emmaandrews
    Participant

    That worked – thank you! Is it possible to create a hover/rollover state for that?

    #1326019

    Joao
    Moderator

    Hi There,

    Please provide your URL and point which section you have applied that.

    Thanks

    #1326038

    emmaandrews
    Participant

    Hi Joao,

    It’s http://www.emmaandrews.me.uk/

    If you click on case studies in the nav it anchors down to the 3 sections I’ve added the link to.

    Thanks v much

    #1326162

    Joao
    Moderator

    Hi Emma,

    In order for this to work in a simple way I would reccomend doing some changes.

    1- Edit the left picture so there is no background color

    2- Remove the background color of the right column

    4- Set the background of your section to grey

    5- Add the following code to Appereance > Customizer > Custom > CSS

    #city-of-bristol-college:hover {
    background-color: black;
    }

    Hope it helps

    joao

    #1326272

    emmaandrews
    Participant
    This reply has been marked as private.
    #1326733

    Nico
    Moderator

    Hi There,

    I could see that you don’t closing braces of your .wpcf7-form class. Check attached for clear view of what I am saying.

    Let us nkow how it goes.

    Thanks.

    Attachments:
    You must be logged in to view attached files.
    #1326949

    emmaandrews
    Participant

    Hey,

    I’ve added the closing bracket but this doesn’t seem to have made a difference. Is there anything else it could be?

    Thanks
    Emma

    #1327053

    Paul R
    Moderator

    Hi Emma,

    Please remove backslash in your css code.

    http://screencast.com/t/7flLrrvFNVH

    Hope that helps

    #1327203

    emmaandrews
    Participant

    Hey,

    that doesn’t seem to have worked either?! If it is a bit complicated I can settle with just using the buttons to interact with/show the hover state.

    Appreciate your help!

    #1327347

    Joao
    Moderator

    Hi There,

    Would you mind providing us with login credentials so we can take a closer look? To do this, you can make a post with the following info:

    – Link to your site
    – WordPress Admin username / password

    Don’t forget to select Set as private reply. This ensures your information is only visible to our staff.

    Thanks

    #1327362

    emmaandrews
    Participant
    This reply has been marked as private.
    #1327627

    Jade
    Moderator

    Hi there,

    Please try this code:

    a:hover #case-studies .x-container .x-column:nth-child(2) {
        background-color: #000 !important;
    }
    #1327685

    emmaandrews
    Participant

    Brilliant – thanks so much, super happy now!

Join the conversation

Register or login to your account to reply.

Purchase for access

Buy a copy of X for access to our member center.

Buy