Product Validation / Extension Page – Connection Issues

This article was last updated on the December 9, 2016.

Themeco requires product validation to provide automatic updates for X and it’s extensions. One of the primary points of failure is that your server is unable to talk to our server and check for updates, or list available extensions.

Common error messages

You may encounter one of these error messages.

Could not establish connection. Please ensure your firewall is not blocking requests to theme.co
Could not retrieve extensions list. Please ensure your firewall is not blocking requests to theme.co

Possible solutions

Here are some suggestions you can try to resolve this issue.

Use the “force-check” flag

Similar to how the WordPress update API is designed, the X extensions page will wait at least 12 hours before checks to our API. This way your dashboard loads faster, as it doesn’t need to make an additional network request.

You can force it to make a request by adding &force-check=1 to the URL. For example:

http://x.dev/wp-admin/admin.php?page=x-addons-extensions&force-check=1

This will often resolve the issue if there was a temporary loss of network connectivity.

Check the PHP error message

It is more likely that this is a problem with your server configuration, and that it is unable to make outgoing network connections, or that somehow theme.co is blocked by a firewall.

You can get more information about the error your server is throwing by adding &x-verbose=1 to the URL. For example:

http://x.dev/wp-admin/admin.php?page=x-addons-extensions&force-check=1&x-verbose=1

This will reveal helpful error messages that you can mention when contacting your host’s support.

Resolve SSL related errors

If the error message is related to SSL, your PHP configuration may not be configured properly. We would advise contacting your host about this. In the meantime, you can fix your WordPress installation by adding this code to a child theme:

add_filter( 'https_ssl_verify', '__return_false' );

This allows WordPress to skip verification when making outbound HTTP requests

Contact your host

Using the error message above, you can contact your webhost. Here is a form letter you may use:

Hello [provider],

My WordPress installation is having a hard time making outbound HTTP requests. I’m using X theme and it makes a request to community.theme.co for setting up automatic updates. Here is the error message I’m receiving:

[screenshot, or copy/paste the verbose error message (see above regarding the &x-verbose flag)]

Could you please do the following?

– Ensure my site can reach this domain: community.theme.co
– Ensure cURL is working, and allow_url_fopen is enabled.
– Ensure PHP is configured with the latest CA Root Certificates.
– Check into the error message above.

Please advise on anything you discover. Thank you.

What if I host myself?

If you’re hosting this yourself, please troubleshoot using the items in the letter above. If you’re getting a 404 error, it’s most likely because you don’t have PHP cURL installed.

Open a support thread

If your host is unable to address the networking issue, we could try to provide more information. When opening a support thread, please include any error messages you encountered during previous troubleshooting. You can open a new thread here